Version down- and upload issue

Mar 28, 2012 at 11:17 AM

Hi!

I ran into an issue when downloading and uploading versions of documents in SharePoint 2010.

I got this message for every file: Exception: GetVersions Web Service call failed

Now I have fixed it be editing some code in the folders2sp.ps1 script:
The line
New-Item -ItemType file  ($versionDir + $versionFile +".xml") -force -value $result.OuterXml | Out-Null
has to be
New-Item -ItemType file $versionFile".xml" -force -value $result.OuterXml | Out-Null

Im Using Windows 2008 R2 SP1 with the current patches and SharePoint 2010 SP1 + Feb 2012 CU Patch

Regards,

Thomas

Coordinator
Mar 29, 2012 at 11:01 PM

Hi Thomas.

Thanks you're right... that would create a duplicate directory structure for version files... I'm also not sure why I'm creating an XML file with version metadata.

I'll update the project.

Regards, Ray. 

 

PS: Thanks for the review.

Sep 17, 2013 at 4:33 PM
Hi,
Thanks for this tool. I'm having an issue when uploading previous versions to SP2010. For previous versions, the Last Modified By (user) field is updated correctly in SP. However, the Modified date is not preserved for previous versions. Instead, the Modified date field for previous versions is set to the Modified date of the latest version.

The xml files created for each previous version in the local script folder do contain the correct version metadata, including Modified date and Last Modified By (user). Again, the script updates Last Modified By (user) correctly but does not update Modified date correctly for previous versions.

Any thoughts?

Thanks,
Jim